Secure HDCP link lost with Transformers, not with others - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-15-2009, 10:32 AM
Member
Thread Starter
 
Join Date: Jan 2009
Posts: 90
Default Secure HDCP link lost with Transformers, not with others

I'm playing HD DVDs on the Xbox 360 add-on, connected via HDMI at 1080p on a 4 year-old LG LCD. The LG is old enough that it has some HDCP handshaking problems occasionally, but it's been fine so far with the 360.

Playing Transformers, though, results in signal blackout every 15-20 seconds, followed by a little Xbox popup stating "Secure HDCP Link Lost," followed shortly by the return of the picture and "Secure HDCP Link Restored."

Could I be hitting the bandwidth limit of my HDMI cable, causing HDCP to get bumped? Is the excellent Transformers transfer sending more info over the HDMI cable than, say, I Am Legend (which doesn't have any issues)? I can't figure out any other reason why HDCP would only flip out on this one title.
Reply With Quote
  #2  
Old 01-19-2009, 02:39 PM
Senior Member
 
Join Date: Apr 2008
Posts: 228
Default

Sounds like a handshaking issue in the copy protection. Try hooking up the component cables that came with the XBox just to test and see if you get the same issue. If it plays fine, then its a handshaking issue and could be your tv/cable/xbox, most likely the tv. One other thing I've heard is sometimes handshaking issues on the XBox 360 can be worked around by plugging into hdmi port 1 on the tv.
Reply With Quote
  #3  
Old 01-19-2009, 09:27 PM
Member
Thread Starter
 
Join Date: Jan 2009
Posts: 90
Default

Thanks. I picked up a Toshiba A3 at Circuit City's liquidation for $35 (why'd they still have it, right?) and the Transformers disc works fine. Guess I'll be setting the 360 drive aside for now.
Reply With Quote
  #4  
Old 03-11-2009, 10:00 AM
Member
 
Join Date: Nov 2007
Posts: 82
Default

i searched everywhere regarding this issue. i got transformers when it was first released. played on the 360 fine through component. i just updated my 360 with the NXE update a few months ago and just yesterday got a new tv LG 47LG70. connected via HDMI, it exhibits the dropouts once every 5-10 min.

apparently this is an issue after the NXE update because i found a thread http://www.avforums.com/forums/xbox-...problem-2.html that talks about this specific thing. it's only isolated to transformers and a few other discs. only option now is go component and 1080i or buy a blu-ray copy
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'N-Secure' is coming June 14 Landy Blu-ray Software General Discussion 0 04-18-2011 11:01 PM
FS: Lost Season's 3 & 4, Transformers (1986) and Others bballplaya210 Blu-ray Disc Exchange 4 05-25-2010 06:22 PM
Microsoft FINALLY acknowledges issue with Paramount/Dreamworks and HDCP link lost channelx99 HD DVD Hardware General Discussion 4 04-22-2010 09:31 PM
Will Wii Fit secure Nintendo's lead indefinetly? Godstar Gaming Smackdown 49 12-13-2007 10:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off