HD-A3 not playing some discs - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-05-2008, 04:10 AM
Member
Thread Starter
 
Join Date: Oct 2008
Posts: 64
Default HD-A3 not playing some discs

Never had this problem before. I have some 2 disc sets and the 2nd disc on some of them won't play at all. The player just says "Loading" and completely freezes. I can't eject the disc, turn the power off, nothing. I have to unplug it from the wall to be able to turn it back on and eject the disc. My firmware is up to date so that isn't the problem and I've tried cleaning the discs with still no luck. They are also brand new without any scratches or damage. It plays all standard DVDs fine and 98% of my HD-DVDs without a hitch, it's only a select few that won't play

Any ideas why or how to fix this? Thanks for any advice you can give
Reply With Quote
  #2  
Old 11-06-2008, 11:52 AM
Junior Member
 
Join Date: Jul 2008
Posts: 24
Default

Try deleting "persistent storage" then re"initialize". The last will set your player back to factory settings. You may want to write down your settings.
(You can find both - setup-general-maintenance) It's a good idea to do this procedure after each firmware update.

Holding down the power button (set is on) for 10 seconds will also reset the player back to factory settings.

Good Luck
Reply With Quote
  #3  
Old 11-06-2008, 05:41 PM
Member
Thread Starter
 
Join Date: Oct 2008
Posts: 64
Default

So just hold down the power button (with the player on) for 10 seconds to reset to factory settings? I'll give it a shot, thanks. I don't think I've changed any (many) settings so I should be able to get them back quickly
Reply With Quote
  #4  
Old 11-06-2008, 07:05 PM
Junior Member
 
Join Date: Jul 2008
Posts: 24
Default

Quote:
Originally Posted by What242 View Post
So just hold down the power button (with the player on) for 10 seconds to reset to factory settings?
Personally, I have used this when my player would not respond to any remote control commands. "Stuck on welcome". I'd use this rather than unplugging the player.

Going to setup/general/maintenance/initialize is the recommended procedure to reset the player.

Firmware 4.0 has solved problems I've had with freezing discs/not a dvd (combo discs).
Reply With Quote
  #5  
Old 11-12-2008, 09:38 PM
darczap's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 1,499
Default

Is this a common problem for the A3? I'm planning on buying my brothers for $50 w/5 HD DVDs. I have an A2, and I've never updated my firmware and never had a problem playing a disc.
Reply With Quote
  #6  
Old 11-14-2008, 10:44 AM
Senior Member
 
Join Date: Jan 2008
Posts: 232
Default

No, it's not a common problem. I own two A3's and there's only one disc that either of them has a problem with (Stalingrad, and the problem is a poorly manufactured disc and this is a common issue with all 3rd generation players and that particular movie). The A3 is a solid unit and will play HD-DVD's and DVD's just fine.

Also, the 4.0 firmware has greatly reduced read errors from less than pristine discs. You'll definitely want to flash to that firmware, which is the latest.
Reply With Quote
  #7  
Old 11-15-2008, 06:56 AM
darczap's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 1,499
Default

How do i go about obtaining the latest firmware for my A2 and my soon to be A3?
Reply With Quote
  #8  
Old 11-16-2008, 06:36 PM
Senior Member
 
Join Date: Jan 2008
Posts: 232
Default

You can download the latest firmware from Toshiba's website.
Reply With Quote
  #9  
Old 11-16-2008, 07:14 PM
darczap's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 1,499
Default

Thanks Doublejack.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My Blu-ray is not playing some features tiny angel Blu-ray Hardware General Discussion 1 09-08-2010 10:01 AM
PS3s Reportedly Not Playing Blu-ray Discs after Firmware Update Attebery Blu-ray Hardware General Discussion 81 12-29-2009 02:29 PM
sony s300 not playing discs civicspeedny Blu-ray Hardware General Discussion 1 12-27-2008 08:23 AM
anyone have problems with the Add-On not playing some discs? WeaselSniff HD DVD Software General Discussion 8 12-10-2007 03:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off