Downgrade firmware for HD-a30? - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-01-2008, 03:18 AM
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 7
Default Downgrade firmware for HD-a30?

I installed the 4.0 firmware on my A30 and suddenly my Batman Begins HD DVD started stuttering and freezing. Several other HD DVDs are acting similarly.

So, I'm figuring the best way to fix this is to roll back the firmware from 4.0 to something more stable. I've been trying to figure it out but nothing yet. Anyone have a modified firmware to roll the player back? Or know how to do it?

Thanks
Mark Santora
Reply With Quote
  #2  
Old 11-01-2008, 09:18 AM
chris gerhard's Avatar
Senior Member
 
Join Date: Apr 2007
Posts: 2,820
Default

I have updated my HD-A30 to 4.0 without any issues yet but I haven't played "Batman Begins" and possibly the others you are having issues with. Have you seen other similar complaints about 4.0? I thought it was very stable based on everything I have read. I don't understand the trick to roll back the player but there was an explanation of how to go back from 3.0 to 2.7 and that technique will likely work with some modification to the files being used.

Chris
Reply With Quote
  #3  
Old 11-01-2008, 03:36 PM
Guns4Hire's Avatar
Senior Member
 
Join Date: Feb 2008
Posts: 1,300
Default

Quote:
Originally Posted by mrsantora View Post
Batman Begins HD DVD started stuttering and freezing. Several other HD DVDs are acting similarly.
Why dont you list all the movies that you are now having problems with using the A30 with 4.0 firmware. That way others can test those discs and you can find out whats actually happening.
Reply With Quote
  #4  
Old 11-04-2008, 01:42 PM
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 7
Default

I ended up modifying the firmware and downgrading it to 2.0. Works fine. Still a little finicky with the HD DVDs and scratches/dust - but that's what a nice cleaning cloth is for.

Mark
Reply With Quote
  #5  
Old 11-04-2008, 02:18 PM
Rich86's Avatar
Senior Member
 
Join Date: Jan 2008
Posts: 4,369
Default

I've been very pleased with the performance of my A-30 under the 4.0 firmware so far. But my discs are pretty much all in pristine condition (if that is the issue here).
I haven't tried playing Batman Begins under the 4.0 firmware however. Where in the movie do folks have problems? hhhhdvd
Reply With Quote
  #6  
Old 11-05-2008, 12:49 PM
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 7
Default

Quote:
Originally Posted by Rich86 View Post
I've been very pleased with the performance of my A-30 under the 4.0 firmware so far. But my discs are pretty much all in pristine condition (if that is the issue here).
I haven't tried playing Batman Begins under the 4.0 firmware however. Where in the movie do folks have problems? hhhhdvd
All my HD DVDs/DVDs/LDs/LPs are in excellent condition. So that's never been it. But it looks to have been resolved. Now I'll try it on the unit in my wife's office. =-)

Mark
Reply With Quote
  #7  
Old 11-06-2008, 09:33 PM
Senior Member
 
Join Date: Dec 2007
Posts: 253
Default

This is why I don't install the latest firmware, my player is still on 1.3 and doing very good.
Reply With Quote
  #8  
Old 07-11-2009, 01:41 AM
Junior Member
 
Join Date: Jul 2009
Posts: 2
Default

Quote:
Originally Posted by mrsantora View Post
I ended up modifying the firmware and downgrading it to 2.0. Works fine. Still a little finicky with the HD DVDs and scratches/dust - but that's what a nice cleaning cloth is for.

Mark

If you don't mind helping out, could you post the .iso file to do this dowgrade of the firmware? Ever since upgrading firmware to 3.0 and then 4.0 I'm getting a greenish tinge on any and all movies I watch. Thanks!
Reply With Quote
  #9  
Old 07-11-2009, 09:59 AM
JAC35's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 2,169
Default

Have you tried unplugging your player? (give it a good reset) BB works fine on my A-30 @FW 4.0. I do know that green screen affect you talk about. I saw it on my HTPC after upgrading PowerDVD 7 no to mention menus missing on the Uni titles. Nasty stuff.... I will search for a link a guy had some ISOs of different versions posted around here somewhere.

*edit* PM Sent

Last edited by JAC35; 07-11-2009 at 12:32 PM.
Reply With Quote
  #10  
Old 07-11-2009, 05:23 PM
Junior Member
 
Join Date: Jul 2009
Posts: 2
Default

Quote:
Originally Posted by JAC35 View Post
Have you tried unplugging your player? (give it a good reset) BB works fine on my A-30 @FW 4.0. I do know that green screen affect you talk about. I saw it on my HTPC after upgrading PowerDVD 7 no to mention menus missing on the Uni titles. Nasty stuff.... I will search for a link a guy had some ISOs of different versions posted around here somewhere.

*edit* PM Sent
jac-- didn't have a PM in the inbox, not sure if you've sent it yet. Thanks!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Study: Netflix Users Inclined to Downgrade on Pay TV -Bad sign for cable/sat operator Kosty High Definition Smackdown 24 06-15-2011 06:59 PM
Datel Files Lawsuit Over Microsoft's Anticompetitive Downgrade of Xbox 360 bbc20000 Gaming Smackdown 158 11-28-2009 03:03 PM
Xbox360 RROD? Expect a downgrade... (rumor) SoylentGreen Gaming Smackdown 79 07-30-2008 04:08 PM
New A3/A30/A35 Firmware Released - 1.3/1.1 ajmiarka HD DVD Hardware General Discussion 14 11-30-2007 12:21 AM
Firmware avaible for A30?? taygan315 HD DVD Hardware General Discussion 2 11-12-2007 03:26 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off