Please Help!! HD-A2 - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-22-2007, 03:00 AM
Senior Member
Thread Starter
 
Join Date: Nov 2007
Posts: 330
Default Please Help!! HD-A2

Please help with this, I'm freaking out that my player is broken. Here's the situation:

I fell asleep watching a disc from the first season of Lost on SD (I'm catching back up to the third season again). When I woke up, I realized the player had frozen on the menu screen.

Nothing I did could stop or turn off the player, including hitting any of the stop or menu buttons or holding down the power button. Finally, I had no choice but to unplug the unit.

Now, after plugging it back in, it powers on normally, but instead of displaying correctly, all I get is green snow on the screen. I have disconnected and reconnected the HDMI, powered down multiple times, both normally and by holding down the button, etc.

It appears to be reading both SD and HD DVD correctly, but it only continues to output green snow. I can't even view the setup menu or anything.

Please help!! What can I do to fix this?
Reply With Quote
  #2  
Old 12-22-2007, 09:44 AM
Senior Member
 
Join Date: Nov 2006
Posts: 8,420
Default

The only thing I can think of is maybe the HDMI output got switched off during the re-set. Try connecting a composite video cable (the yellow RCA jack cable) to your TV and go into the player's Setup menus to check settings.

If you can't see anything but "green snow" via composite video, your player is probably fried. But, if you have a component cable set (the red, green, blue cables), try them as well.
Reply With Quote
  #3  
Old 12-22-2007, 01:56 PM
Senior Member
Thread Starter
 
Join Date: Nov 2007
Posts: 330
Default

Thanks, I ended up getting it back early this morning. I posted this at 2 am when I woke up and discovered the problem. After messing with it and posting this, I tried to go back to sleep, but I couldn't sleep.

It seemed to be an HDMI issue, but I still don't know if what I did fixed it, or if it was just a fluke.

I unplugged the TV, the HDMI cable from both the player and the TV, and then I unplugged the player. I waited a few minutes, then, I plugged in the TV again, then hooked up the player via HDMI, then plugged in the player and turned it on. When it came back on again, it worked and the green snow was gone. So now I can stop freaking out, thank God!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP HELP HELP Sony Bravia DAVDZ170 Markucho Home Theater Gear 2 01-21-2013 06:47 PM
Please be Quake 5, please be Quake 5, please be Quake 5.... Favelle Game Room 12 07-25-2012 12:21 AM
Help!!! Help!!!! Help!!!! nufnman Blu-ray Hardware General Discussion 2 10-14-2007 08:50 PM
Please Help me find a good audio solution! messin18 Home Theater Gear 4 12-15-2006 06:24 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off