Is my A2 a lemon? - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-11-2007, 08:35 PM
Gouty's Avatar
Senior Member
Thread Starter
 
Join Date: May 2007
Posts: 185
Default Is my A2 a lemon?

Iíve had my A2 for roughly two weeks now and when things are running smoothly I couldnít be happier. However Iíve watched three movies on it thus far and at one point or another the player has froze on every disc. It only froze once per movie, and had no problems playing the same portions the second time through. Iím running the 2.5 firmware. Is anyone else experiencing this or is my unit defective?
Reply With Quote
  #2  
Old 11-11-2007, 08:52 PM
ScoBro828's Avatar
Senior Member
 
Join Date: Sep 2007
Posts: 2,497
Default

Quote:
Originally Posted by Gouty View Post
Iíve had my A2 for roughly two weeks now and when things are running smoothly I couldnít be happier. However Iíve watched three movies on it thus far and at one point or another the player has froze on every disc. It only froze once per movie, and had no problems playing the same portions the second time through. Iím running the 2.5 firmware. Is anyone else experiencing this or is my unit defective?
Actually I have the A3 and have run into similar problems.
Reply With Quote
  #3  
Old 11-11-2007, 09:06 PM
Member
 
Join Date: Nov 2007
Posts: 91
Default

No problems here. Sounds like a defective unit.
Reply With Quote
  #4  
Old 11-11-2007, 10:15 PM
Gouty's Avatar
Senior Member
Thread Starter
 
Join Date: May 2007
Posts: 185
Default

If anyone else has the A2 and your unit has ever froze with the 2.5 firmware, even if it was an isolated incident, please post. Iím trying to gauge if my player really has a problem or if Iíve just been on an unlucky streak and they all freeze once in awhile.
If I take my unit back to Circuit City, wonít they have to give me the A3? Iíd like to keep the A2 but they canít replace what they donít have.
Reply With Quote
  #5  
Old 11-11-2007, 10:26 PM
RoadLizard's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 3,076
Default

Quote:
Originally Posted by Gouty View Post
If anyone else has the A2 and your unit has ever froze with the 2.5 firmware, even if it was an isolated incident, please post. Iím trying to gauge if my player really has a problem or if Iíve just been on an unlucky streak and they all freeze once in awhile.
If I take my unit back to Circuit City, wonít they have to give me the A3? Iíd like to keep the A2 but they canít replace what they donít have.
My A2 has had only ONE instance where a disc was completely unplayable and that was my first copy of 300. Other than that, I have had minor stutters and skips over the course of the last 5 months Ive had it but to answer your question, I have NOT had a single issue at all since my 2.5 update which I did about a month or so ago.
Reply With Quote
  #6  
Old 11-12-2007, 08:43 AM
Scripture's Avatar
Senior Member
 
Join Date: Nov 2007
Posts: 2,093
Default

Quote:
Originally Posted by Gouty View Post
If anyone else has the A2 and your unit has ever froze with the 2.5 firmware, even if it was an isolated incident, please post. Iím trying to gauge if my player really has a problem or if Iíve just been on an unlucky streak and they all freeze once in awhile.
If I take my unit back to Circuit City, wonít they have to give me the A3? Iíd like to keep the A2 but they canít replace what they donít have.
I haven't experienced this yet, knock on wood. Updated to the 2.5 firmware on mine as well. I have a japanese model (made sure of that when buying), not sure if it makes a difference to you or not. For a peace of mind, see if they can order you another A2 unit. If not, then try a few more movies and see what happens. If you deem it to be a persistent problem, then I would most definitely exchange it for an A3. The way I see it, a working/functional player is better than a malfunctioning/glitchy player.

If not that route, then you could always contact Toshiba to get it repaired. I think Circuit City could send it to someone as well. I would talk with them at the store though, speak with the manager or another higher up representative. Explain the situation, they should be able to do something for you.
Reply With Quote
  #7  
Old 11-12-2007, 10:25 AM
Arnie's Avatar
Senior Member
 
Join Date: May 2007
Posts: 111
Default

I have the A2 with the most recent firmware & have had no problems at all with SD or HD.
Reply With Quote
  #8  
Old 11-12-2007, 11:15 AM
Liqwid's Avatar
Senior Member
 
Join Date: Jun 2007
Posts: 4,170
Default

I've had only one problem, and it was with "A Clockwork Orange". I need to re-watch it tonight to see if there are any problems with the disc they sent me this time.
Reply With Quote
  #9  
Old 11-12-2007, 11:21 AM
FreddyC's Avatar
Senior Member
 
Join Date: Jul 2007
Posts: 706
Default

Before taking it back, make sure you have not got any dust or scrapes on the discs. I had a lock up awhile back with a Netflix movie. I took a cloth and wiped it down really good and didn't have any more problems. Freddy
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sharp BD-HP21U--did I get a lemon? cheez avenger Blu-ray Hardware General Discussion 8 05-12-2009 06:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off