Anyone having issues with HD-A2 and Monoprice HDMI switchbox? - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-22-2007, 04:21 PM
wingnut's Avatar
Senior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 2,223
Default Anyone having issues with HD-A2 and Monoprice HDMI switchbox?

Recently ordered the Monoprice3x1 HDMI switcher and can't seem to get it to work with my Toshiba HD-A2. After a couple of minutes of playing the screen goes black, if I skip to the next chapter or fast forward a bit it comes back, then another couple minutes it goes black again. Tried it with out the switcher hooked up to the TV and it plays fine, tried differnet cables, different ports on the switcher, an the A2 is at it's current firmware update. My 360 and Ps3 work fine on the switchbox, just my A2 is having issues.

Anyone else having the same problem?
Reply With Quote
  #2  
Old 10-22-2007, 05:04 PM
Senior Member
 
Join Date: Nov 2006
Posts: 8,420
Default

Quote:
Originally Posted by wingnut View Post
Recently ordered the Monoprice3x1 HDMI switcher and can't seem to get it to work with my Toshiba HD-A2. After a couple of minutes of playing the screen goes black, if I skip to the next chapter or fast forward a bit it comes back, then another couple minutes it goes black again. Tried it with out the switcher hooked up to the TV and it plays fine, tried differnet cables, different ports on the switcher, an the A2 is at it's current firmware update. My 360 and Ps3 work fine on the switchbox, just my A2 is having issues.

Anyone else having the same problem?
Hmm, strange - I used the Monoprice 2 port switch for almost a year with my XA1 and had no problems at at all.

I've been helping a guy on another forum that's been having a similar problem with an A2 to the DVI input on his HDTV - same problem of picture fading in & out. I've been telling it must be his TV as if my player ever loses the HDMI connection it immediately displays the "No HDMI LInk" and the LED, and then stops. Never heard of the picture fading in & out before. Well, it sounds like your Monoprice switch is fine if your PS3 & Xbox are happy with it. I guess component is not an option?

Sorry can't be more helpful.
Reply With Quote
  #3  
Old 10-22-2007, 06:22 PM
RJ Munkey's Avatar
Junior Member
 
Join Date: Oct 2007
Posts: 2
Default

I had/have the same problem with the MonoPrice 4x1 switch...it kept dropping the signal exactly like you described. I tried two other switches (a Terk self switching model and a Psyclone model, both from Best Buy)...I experienced the same problems with those switches.

I finally connected the HD-A2 via component (my HDTV is only a 720P model anyway) and it works fine. I never did get any of the HDMI switches I tried to work with the A2. I know that's not very reassuring, but I just didn't want you to think that your problem was unique. Seems taht HDMI can be very temperamental.
Reply With Quote
  #4  
Old 10-22-2007, 07:56 PM
Banned
 
Join Date: Jun 2007
Posts: 1,996
Default

No problems with mine......
Reply With Quote
  #5  
Old 10-22-2007, 09:47 PM
Arkadin's Avatar
Senior Member
 
Join Date: Mar 2007
Posts: 12,401
Default

maybe a new hdmi cable would work with the A2. That's all I can think of. I ordered my hdmi cables from www.svideo.com
and I love them (if that's possible with a friggin' cable)
I got the blue ps3 ones.
Reply With Quote
  #6  
Old 10-23-2007, 03:21 AM
rizzlehd's Avatar
Senior Member
 
Join Date: Nov 2006
Posts: 256
Default

My HD-A2 works perfectly w/ that same monoprice HDMI switcher
Reply With Quote
  #7  
Old 10-23-2007, 12:38 PM
wingnut's Avatar
Senior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 2,223
Default

Quote:
Originally Posted by rizzlehd View Post
My HD-A2 works perfectly w/ that same monoprice HDMI switcher
It's good to know that at least there is a chance it will work. I'm currently using all monoprice cables, I wonder If getting a higher grade cable will fix the issue.
Reply With Quote
  #8  
Old 10-24-2007, 11:15 AM
Coaler's Avatar
Senior Member
 
Join Date: Oct 2007
Posts: 1,331
Default

Quote:
Originally Posted by wingnut View Post
It's good to know that at least there is a chance it will work. I'm currently using all monoprice cables, I wonder If getting a higher grade cable will fix the issue.
I have the exact setup and it works. I have my PS3,A2,and HD PVR hooked up to it. Have you tried hooking your PS3 to the input you are using for your A2? I have a funny feeling you may have a bad input. Give it a try and let me know. Perhaps also contact monoprice and they may send you a replacement.
Reply With Quote
  #9  
Old 10-24-2007, 12:00 PM
wingnut's Avatar
Senior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 2,223
Default

Quote:
Originally Posted by Coaler View Post
I have the exact setup and it works. I have my PS3,A2,and HD PVR hooked up to it. Have you tried hooking your PS3 to the input you are using for your A2? I have a funny feeling you may have a bad input. Give it a try and let me know. Perhaps also contact monoprice and they may send you a replacement.
Yeah, I tried all 3 ports with the A2. I ordered a couple of Monster cables to see if that's the problem. If those don't work I'll try returning it to Monoprice for an exchange. I just hope it's not my TV that's finnicky.
Reply With Quote
  #10  
Old 10-24-2007, 01:02 PM
Coaler's Avatar
Senior Member
 
Join Date: Oct 2007
Posts: 1,331
Default

Quote:
Originally Posted by wingnut View Post
Yeah, I tried all 3 ports with the A2. I ordered a couple of Monster cables to see if that's the problem. If those don't work I'll try returning it to Monoprice for an exchange. I just hope it's not my TV that's finnicky.
It's not your cables. I use the monoprice $4 6ft HDMI cables for my entire setup (i believe 6 in total.) I also hope its not your TV but you said it works without the switcher so i doubt its the TV. I would try exchanging the switch.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS: Yamaha RX V663 7.2 channel 665 Watt Receiver and Monoprice 4x1 HDMI switcher badasscabletech Home Theater Gear: Buy/Sell/Trade 2 12-11-2010 08:22 AM
Manhunt 2 on the Wii - anyone else having freezing issues? IceNine Game Room 0 11-21-2007 05:13 PM
Can anyone tell me the difference between Monoprice 2.4 and 2.5 rev. hdmi switches?? EmemberBuhWeet Home Theater Gear 1 11-11-2007 03:54 AM
Anyone having Blockbuster Online issues this week? jgantert General Discussion: Both Formats 2 05-03-2007 12:58 PM
Problems with my HD-A2 and Monoprice HDMI switcher... Joe6pack HD DVD Hardware General Discussion 9 04-12-2007 07:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off