Onyko 605 problems! Help! - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-21-2007, 09:14 AM
Senior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 272
Default Onyko 605 problems! Help!

I have a Onyko 605 reciver and a Toshiba XA2 plus a Panasonic DMP-BD10a. I cant get the 605 to display the TRUE-HD on the front of the 605 when i play a movie with the TRUE-HD track. I have both players set up thru an HDMI cable. What do i set each player to? Then what do i set the 605 to? I sure hope i can get this to work. I also have both players updated qith the last newest update. (2.5 & 2.4)
Reply With Quote
  #2  
Old 10-21-2007, 09:44 AM
LastSonOfKrypton's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 2,229
Default

The only HD DVD player that can bistream TrueHD to the reciever is the HD-A35 so unless you trade in your XA2 for that you aint gonna see it. Every other player internally decodes it and sends it as PCM.

As far as Blu goes I know the Sammy 1400 can bitstream DTS-MA, I don't know if it can do TrueHD, DD+, or DTS-HD. As far as I know that's the only player of bitstream capabilities.
Reply With Quote
  #3  
Old 10-21-2007, 11:01 AM
anavrin0901's Avatar
Senior Member
 
Join Date: Feb 2007
Posts: 617
Default

I have the 605 and that is the reason I bought the A-35. Sorry but unless they give you a firmware update you are out of luck for the moment.
Reply With Quote
  #4  
Old 10-21-2007, 11:59 AM
Westonian's Avatar
Senior Member
 
Join Date: Aug 2007
Posts: 163
Default

Of course, not seeing the TrueHD logo light up on the receiver is the ONLY difference between the two when it comes actually hearing the TrueHD audio track.
Reply With Quote
  #5  
Old 10-21-2007, 01:57 PM
Senior Member
 
Join Date: Aug 2007
Posts: 542
Default

Yeah even though its PCM your still hearing true HD
Reply With Quote
  #6  
Old 10-21-2007, 02:26 PM
pkremer's Avatar
Senior Member
 
Join Date: Apr 2007
Posts: 1,016
Default

Quote:
Originally Posted by dachst8087 View Post
I have a Onyko 605 reciver and a Toshiba XA2 plus a Panasonic DMP-BD10a. I cant get the 605 to display the TRUE-HD on the front of the 605 when i play a movie with the TRUE-HD track. I have both players set up thru an HDMI cable. What do i set each player to? Then what do i set the 605 to? I sure hope i can get this to work. I also have both players updated qith the last newest update. (2.5 & 2.4)
And you won't be able to. That is because the HD-DVD player decodes the TrueHD track onboard, which means the HD-DVD player is doing the decoding. It is then sending the TrueHD track to your receiver as uncompressed PCM (which I assume is what the 605 is telling you, PCM). You are actually hearing the TrueHD track, it is simply your HD-DVD player decoding and not your 605.

Strangely enough, the 605 decodes all these tracks, but so far, it hasn't had to. Most new players decode the new codecs on board. There is a Samsung Blu-ray player that sends DTS-HD-MA to the receiver to be decoded, but that is all I know of currently.

In short, you are hearing the TrueHD track with your 605. Isn't it great?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Onyko 605 firmware Update? dachst8087 Home Theater Gear 8 04-12-2008 01:19 AM
Newbie problems with A35 and Onkyo 605 No One Ix HD DVD Hardware General Discussion 8 12-22-2007 08:10 PM
Panasonic DMP-BD10A & Onyko 605 HELP dachst8087 HD DVD Bargains 3 10-18-2007 12:41 AM
Onkyo 605 - Subwoofer Help. thestaton Home Theater Gear 3 10-12-2007 01:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off