Problem with blue-ray underdog! - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-25-2007, 12:04 AM
Member
Thread Starter
 
Join Date: Dec 2007
Posts: 47
Question Problem with blue-ray underdog!

HI, This is my first time posting. I have just bought the Sony BDP-S300 player with a copy of underdog. I Got home hooked up the player and staterd playing underdog. The first viewing was great. then I Called sony to request a firmware update disc. (BDP-S300/301) I recived the disc a few days later. Put the disc in the player and updated the firmware. I Then checked the firmware update on my systems setings and it did updated the firmware. At this time i did have the newest Version. I then decided to boot up underdog again, only this time it would not play!! It will go to the title screen but when you hit play or chapter search the sreen freezes up. i then called sony and I was told that i did have the current firmware update so this is not the problem. they told me to take it back to the store and get a new disc. I did this and it still does the same thing. I Then whent online and found that there is another firmware update. i was told that i need to update the player again and then it will play fine. So I Called to order a new firmware disc.( since i dont know how to down load it from the website) I Just wanted to share this with you guys and to see if any of you have had this problem. Maybe its just me but it shure seems that every time a new blue-ray disc comes out you need a firmware updated disc to go with it. I Gess its the java thing that sony uses that makes these disc not play. What do you guys think. buy the way i love this blue-ray player. it is slow but the picture is so great it makes up for the long load times. Thank you for reading this post i know it is long.
Reply With Quote
  #2  
Old 12-25-2007, 12:19 AM
Banned
 
Join Date: May 2007
Posts: 1,287
Default samsung bd-p1200

read the problems with this puppy in the hardware discussion...the Sony is usually very good..but the Samsuck player is brutal..and no firmware for over 2 months now
Reply With Quote
  #3  
Old 12-25-2007, 06:37 PM
taygan315's Avatar
Senior Member
 
Join Date: May 2007
Posts: 7,536
Default

Quote:
Originally Posted by atari52 View Post
HI, This is my first time posting. I have just bought the Sony BDP-S300 player with a copy of underdog. I Got home hooked up the player and staterd playing underdog. The first viewing was great. then I Called sony to request a firmware update disc. (BDP-S300/301) I recived the disc a few days later. Put the disc in the player and updated the firmware. I Then checked the firmware update on my systems setings and it did updated the firmware. At this time i did have the newest Version. I then decided to boot up underdog again, only this time it would not play!! It will go to the title screen but when you hit play or chapter search the sreen freezes up. i then called sony and I was told that i did have the current firmware update so this is not the problem. they told me to take it back to the store and get a new disc. I did this and it still does the same thing. I Then whent online and found that there is another firmware update. i was told that i need to update the player again and then it will play fine. So I Called to order a new firmware disc.( since i dont know how to down load it from the website) I Just wanted to share this with you guys and to see if any of you have had this problem. Maybe its just me but it shure seems that every time a new blue-ray disc comes out you need a firmware updated disc to go with it. I Gess its the java thing that sony uses that makes these disc not play. What do you guys think. buy the way i love this blue-ray player. it is slow but the picture is so great it makes up for the long load times. Thank you for reading this post i know it is long.
Welcome to the site. Your post is not that long. Say what you want to say. Everyone else does.
Reply With Quote
  #4  
Old 12-26-2007, 01:48 AM
REDMAN's Avatar
Senior Member
 
Join Date: Nov 2007
Posts: 459
Default

I've had the BDPS300 for about a week now and I have yet to have any issues.

I've updated my player to Firmware 3.70 and so far it has played my discs flawlessly.

I'll try Underdog in the next day or so and respond back.
Reply With Quote
  #5  
Old 12-26-2007, 03:58 AM
Dark Lord Greg's Avatar
Senior Member
 
Join Date: Nov 2007
Posts: 1,305
Default

i think that the real proble is that you actually paid for and watched underdog, but really it sounds like a firmware problem
Reply With Quote
  #6  
Old 12-26-2007, 09:26 AM
Member
Thread Starter
 
Join Date: Dec 2007
Posts: 47
Default

Well if you grew up on the cartoon you would have bought underdog too. To Be truthful with you I think it sucked.
Reply With Quote
  #7  
Old 12-26-2007, 09:31 AM
Member
Thread Starter
 
Join Date: Dec 2007
Posts: 47
Default

I Think it is a firimware problem my self. But the thing i cant understand is why would it play great before the firmware update and not play after the update? I Think your beter off if you dont update the firmware. anyway i will let you guys know if it playes after i recive the new firmware update disc. This is the only disc i have had a problem with so far.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'Underdog' -- pre-release buzz PeterB Blu-ray Software General Discussion 13 01-15-2008 10:56 AM
"Underdog" Coming To Blu-Ray in Dec. Arkadin Blu-ray Software General Discussion 2 09-15-2007 12:29 AM
Is Blu-ray the real HighDef underdog? VC-1 High Definition Smackdown 86 05-24-2007 10:48 PM
USA Today calls out Sony: 'from top dog to underdog in record time' BSC Gaming Smackdown 22 03-23-2007 10:23 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off