Juan of the Dead Audio Issue - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-29-2016, 01:07 PM
Laguz's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Posts: 58
Default Juan of the Dead Audio Issue

I bought Juan of the Dead on blu-ray over a year ago. The two Spanish audio tracks had the same problem; the center channel audio was also coming out of the rear right speaker. However, the English audio worked fine.
Now, I just bought it again. SAME issue! This is the ONLY movie I have this issue with.

The Spanish tracks are in 5.1 Dolby Digital and DTS-HD Master Audio. The English track is just 2.0 Dolby Digital, which would explain why the English track sounds ok.

Anyone else have this trouble? Anyone know if it could SOMEHOW be a system problem? Anyone know how to contact the damn company that made this stupid disc???

Btw, i have the Yamaha RX-V373.

Last edited by Laguz; 11-29-2016 at 01:18 PM.
Reply With Quote
  #2  
Old 11-30-2016, 12:44 AM
Krawk's Avatar
Mod, Staff, Movie Buff
 
Join Date: Apr 2008
Posts: 13,877
Default

Have you tried their website?
http://entertainmentone.com/home
__________________
Keep Physical Media Alive, Just say NO to digital "ownership"
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'Juan of the Dead' is coming September 16 Landy Blu-ray Software General Discussion 0 07-28-2014 12:42 PM
'Don Juan DeMarco' - High-Def Digest Review Attebery Blu-ray Software General Discussion 0 04-18-2012 06:09 PM
'Don Juan DeMarco' is coming April 10 Landy Blu-ray Software General Discussion 0 12-14-2011 01:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off