sony s300 not playing discs - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-26-2008, 09:44 PM
civicspeedny's Avatar
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 25
Default sony s300 not playing discs

i got a bunch of few new movies for xmas and every one i put in loads the menu but once i play the movie it plays for a second then the whole system shuts off and turns back on, the movies its done this with are death race and wanted but all my old movies still work fine and i think i have the latest firmware update,anyone have any idea whats wrong?
Reply With Quote
  #2  
Old 12-27-2008, 08:23 AM
SickSol's Avatar
Senior Member
 
Join Date: Jan 2008
Posts: 486
Default

I would double check and make sure you have the right firmware. If you do it might be the actual disks. As some people were having play back problems with wanted.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HD-A3 not playing some discs What242 HD DVD Hardware General Discussion 8 11-16-2008 07:14 PM
anyone have problems with the Add-On not playing some discs? WeaselSniff HD DVD Software General Discussion 8 12-10-2007 03:11 AM
Sony BDP-S300 Trouble with Data Discs? dsage215 Blu-ray Hardware General Discussion 0 12-01-2007 11:38 PM
Sony BDP-S300 $399 at sony style (100 dollars off with sony CC) spicynacho High Definition Smackdown 1 11-22-2007 01:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off