BDP S301 audio won't work - High-Def Digest Forums
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-25-2008, 12:37 PM
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 2
Default BDP S301 audio won't work

I just bought a BDP S301 and hooked to up to my sony receiver STR-DG1000 with an HDMI cable. Then the receiver is hooked up to a front projector. I have picture but I can't get sound. The first sony rep said I needed to update the firmware (I have 3.2), the second rep said the firmware was fine I just need to unplug and plug it back in. Nothing has worked. I'm not sure what the audio settings should be on the Blu-ray and the receiver. Can anyone help?
Reply With Quote
  #2  
Old 02-25-2008, 11:27 PM
un4gvn94538's Avatar
Member
 
Join Date: Dec 2007
Posts: 51
Default

have you used the hdmi on your receiver before? was it working then?
all i can think of is the problem i had with my onkyo.
i could not get any sound out because of a setting on my receiver. i had to enable hdmi sound in my receiver. i cant remember exactly what it was called. perhaps your having the same issue
Reply With Quote
  #3  
Old 02-26-2008, 04:56 AM
DeanWG's Avatar
Senior Member
 
Join Date: May 2007
Posts: 410
Default

Does the BD player have HDMI audio settings in the set-up menu? Is it disabled for some reason? Does it have a setting for PCM/bitstream? If so, what is it set at?

Have you tried optical to see if your receiver can at least pick that up?

It does sound to me like it might be a problem with the settings of your receiver as opposed to the player. Make sure to check the HDMI audio settings on your receiver, something like "pass through" or something. What it might be doing is passing the signal to your display to output the sound there (which won't work for you), and ignoring the sound internally.
Reply With Quote
  #4  
Old 03-04-2008, 04:56 PM
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 2
Default

Thanks for the help. It turns out I had to reset the receiver to the factor settings and then the HDMI inputs would work properly. I only have the cable and Blu-ray hooked up to the receiver and they are now on the two HDMI inputs and working properly.
Reply With Quote
  #5  
Old 03-04-2008, 10:56 PM
Junior Member
 
Join Date: Nov 2007
Posts: 8
Default Sound Problems

FYI, I also had some problems on a few movies that I had to just keep turning the player on and off for. The background sound would come on but no voices, then after reset I would get sound sometimes. Mine was through the optical output though. Sounds like you worked it out though.
Reply With Quote
  #6  
Old 03-05-2008, 02:12 AM
mrspeakers's Avatar
analog/digital audio expert
 
Join Date: Sep 2007
Posts: 650
Default

With HDMI, turn on sequence can be important.

Always turn on the TV first, wait a minute for it to be fully on, then turn on the receiver, then the players.

My BD30 loses it's brain when I change the audio from DD to TrueHD, for example, and I have to switch source on the receiver away from then back to the BD30 to get audio.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sony BDP-S780, BDP-S580, BDP-S480, and BDP-S380 pricing information and some details HDTV1080P Blu-ray Hardware General Discussion 3 02-24-2011 05:16 AM
BDP-S300/ S301 Satisifed or Not Satisifed? ScorpionKingCT Blu-ray Hardware General Discussion 1 11-30-2007 02:45 PM
Sony Bdp-s301 $279 At BJ'S Till 11/25 dominica Ultra-HD/Blu-ray Bargains 0 11-21-2007 09:36 PM
Sony BDP-S301 for $450 with HDMI cable! dvdirv Ultra-HD/Blu-ray Bargains 0 07-27-2007 08:57 AM
BDP-S301 to New Zealand? [email protected] Blu-ray Hardware General Discussion 0 07-22-2007 06:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off