Results 1 to 3 of 3
  1. #1
    Eastmancolor is offline Member
    Join Date
    Oct 2016
    Posts
    1

    Default OPPO BDP-93 Picture Freezing, Sound Drop-Outs

    I've had my OPPO BDP-93 for around 5 years. All has been well until recently.

    After approximately 3-4 hours of use, there are problems with playing back discs. The image freezes for a second or two and audio will drop out. This will occur every 10-15 seconds.

    No problems with the discs. The issue doesn't occur at the same place on the disc each time.

    Have switched out HDMI cables and still the problem persists. Have bypassed my receiver and gone direct into my Epson projector, the problem is still there.

    Nothing has changed setting-wise with the player. The problem started around two weeks ago. Can watch two average length features in a row and the problems start by the end of the second feature, or into a third.

    So I think it's the OPPO player. Has the latest firmware. Also my player was modified to be region free, from Bombay Electronics out of Chicago, where I purchased it years ago.

    Has anyone else had an issue with their players after the machine has warmed up? Circuitry issue? My player sits in an open area with plenty of ventilation, so it shouldn't be overheating.

  2. #2
    Krawk's Avatar
    Krawk is online now Super-Duper Mod
    Join Date
    Apr 2008
    Location
    Maine
    Posts
    10,318

    Default

    Sounds more like a laser/drive issue than anything. But I am just figuring based on the info you have given. As a general rule those "laser lens cleaners" are a complete gimmick so don't waste your money there.
    I have an Oppo 103D myself but when I first started with 2nd or 3rd gen BD players I had a phase where I was trying LG. Every single one I had would do that same thing after 4 months or so.
    Keep Physical Media Alive, Just say NO to digital "ownership"

  3. #3
    solarrdadd's Avatar
    solarrdadd is offline Member
    Join Date
    Dec 2016
    Posts
    20

    Default

    I have a 93 and it has an external USB/rs232 Region free mod and I don't have any of the issues you mentioned. can you tell us is it limited to certain disc or only after a given amount of usage time? are the disc "other region" discs or any region discs? I've watched 4-5 episodes of Game of Thrones with my 93 with no problems.

    perhaps a few more details could help us help you better. of course, if it's not attached/associated with any particular discs at all, then yeah, it's possible that it's just your machine giving up the ghost. I'm sure oppo will be willing to fix it if you want to keep it.
    55" Sony SXRD KDS-55A2000 1080P
    PS3 Slim x2 & XBOX 360 Elite, iPhone6+ 128gb
    iPad4 64gb, AppleTV-hdmi x2, NAS-4tb, Oppo BDP-105D, 105, 93 players
    Marantz AV7702MKII Pre/Pro; NR-1607 receiver; Audioquest XLR & RCA interconnects, iFi iDSD DAC & iUSB, Axiom Spkrs M80v3, VP180v3, QS8v3, QS4v3! Emotiva XSP-1, XPA-5, UPA-2, UPA-200/700, & mini-x Amp, X-Ref 12 DSP Sub & Ultra Subs 12, Pro-Ject Debut 3 TT, Polk Audio SDA-2 & Monitor 10A/5A Peerless Tweeters
    ATMOS/DTS:X 7.1.4/5.1.2 NYGIANTS!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Content Relevant URLs by vBSEO 3.5.1 PL1